Intermediate Excel 2003

Part A: Working with Formulas and Hyperlinks
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1) Entering Formulas

Formulas in Excel are a powerful way of utilizing the applications mathematical and logical abilities.
Formulas can be entered manually or with the use of the formula icon

a) Select the cell where calculation is to appear
b) Type the equal sign (=) and then type the formula followed by the cell parameters (i.e. =difference(A7

- B7)).
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Intermediate Excel 2003

Alternatively [
a) Select the cell where the calculation is to appear = - :
b) Click on the Insert Function icon to the left of the Search for a function:
formula bar I';.-'|:l-Ee a brief description of what wou wank to do and then
click, 3o
Or seleck a category: | Most Recently Used v
~ M J & =ER+ES+E1 Select a Function:
E B b
- - — MEDIAM
QUARTILE
UM
AYERAGE
. IF i
¢) Select a function from the drop down menu or type a e M
brief description of what you want to do and then STDEVA(valuel,value2,..)
click Go Estimates standard deviation based on a sample, including logical values and

text. Text and the logical value FALSE have the value 0; the logical value
TRLE has the value 1,

Help on this Function [ oK ] [ Cancel

Tip: To see all your formulas at once within your workbook press Ctrl+ ~. Repeat the key stroke to
return to normal view.

To enter multiple formulas more quickly use the fill command

2) Entering Data More Quickly: The Fill Command
a) Select the cell to be copied
b) Position the mouse pointer over the selected cell
¢) Drag the fill handle (cursor turns into a small black cross) in the lower right corner of the selected cell
to highlight the cells into which you want to copy the entry and release the mouse button.

3) AutoFill
a) To enter a series such as the days of the week, type Monday into a cell
b) Drag the fill handle in any direction to select six more cells
¢) Release the mouse button
d) Excel inserts the remaining days of the week, in order, into the selected cells. (You can also AutoFill
the months.)

4) Merging Cells (Merge and Center)
a) Enter Text into upper-leftmost cell that is to be merged and centered
b) Select the cells you want to merge.
¢) To merge cells in a row or column and center the cell contents, click Merge and Center

on the formatting toolbar
Merge and
Center button

5) Changing Text Direction in a Cell

a) Click on cell containing text to change

b) Click on Format on the Menu Bar, select Cells and click on the Alignment tab

c) Select the amount of degrees for the text direction

d) Click OK; text will be changed
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6) Wrapping text within a cell.
a) Click on cell containing text to change
b) Click on Format on the Menu Bar, select Cells and click on the Alignment tab
¢) Under text control check Wrap Text
Note: It may be necessary to adjust the row height on the cell you wish to wrap text in. (See #21).

7) Adding a comment
You can insert useful information that will pop up whenever the cursor is positioned over the cell.
a) Select the desired cell.
b) Right click and select Insert Comment
c) Type the desired text

8) Inserting and naming a New Worksheet in your Workbook
a) Click on the Insert menu and select Worksheet
b) A new worksheet called Sheetl will be added to the worksheet tabs in the lower left corner.
¢) Click on and drag the worksheet tab to change the order of the worksheets.
d) To rename your sheet, right click on the worksheet tab and select Rename.

9) Linking Cells within a worksheet
Linking cells is useful if you want cell data to report the output of a formula cell in another worksheet.
a) Select the cell that you want the data to show up in.
b) Press the “=" button
c) Enter the cell address containing the desired information OR click on the desired cell itself by clicking
first on the appropriate worksheet tab and then navigating to the cell.
d) Press enter

Note: Clicking on the linked cell will result in a formula such as =Sheet1!F17. Sheetl! References the
worksheet where the original data lives and F17 is the cell address within that worksheet.

10) Linking Cells within a worksheet using Paste Special
This feature is similar to the previous instruction, but has the added luxury of allowing you to link
multiple formulas from different cells all at the same time.
a) Highlight the cells that contain the data and formulas which you would like to link to.
b) Copy the cells (Edit=>Copy or Ctrl+C)
c) Highlight the cells where you want the linked data to show up.
d) From the Edit Menu select Paste Special
e) Clink on the Paste Link button.

11) Hyperlinking Cells
This feature allows you to navigate between linked cells in multiple worksheets
a) Highlight the cell or cells you would like to hyperlink from.
b) From the Insert Menu select Hyperlink (or press Ctrl+K)
¢) In the Insert Hyperlink Dialog box click on the Place in this Document button
d) Select the appropriate worksheet within the workbook
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e) If necessary enter a cell address within the desired worksheet.

Additional Formatting Tips and Tricks

| [&]% 5 3

i

12) Formatting Tips: Currency, Percent, Commas and Decimals
Located on the Formatting Toolbar
a) Use the $ icon to quickly change numbers to currency values
b) Use the % icon to quickly chance numbers to percents
¢) Use the comma (,) icon to quickly insert commas appropriately into large numbers
d) Use the increase/decrease decimal icon to quickly change the number of significant figures on your
numbers.

13) Conditional Formatting

Use conditional formatting to monitor formula results or other cell values by applying conditional formats.
For example, you can apply green text color to the cell if sales exceed forecast and red shading if sales fall
short.

a) Highlight the cells to which you would like to

apply the conditional formattin Condtionl :
b) CPECIZ on the Format menu and felect CellValue 1> [pa [betneen ) 4 S
.. . Preview of format ko use F ;
Conditional Formatting e e 5 e ‘ AaBbCcYyZz ‘

c) Identify the parameters for the desired cells
(i.e. greater than 50 and less than 80)

d) Click on the Format button and select the desired formatting for cells that fit your defined parameter.
(i.e. bold face type or a different color text).

e) Click on Add to insert more parameter conditions.

f) Click OK

[ Add == ][ Delete. .. ] [ [0]4 ][ Cancel ]

s

14) Adding a textbox
(Useful for adding directions or notes about the spreadsheet. These textboxes can be colored and moved
about the worksheet) 3
a) Turn on the Drawing Toolbar (View, Toolbars, Drawing). = | Textbox
b) Select the textbox icon. Button
¢) Click and drag on the spreadsheet to size the textbox
d) Click inside the textbook and enter text.
e) Format the textbox properties (font and background coloring) by double clicking on a corner of the

textbox.

15) Finding and Replacing Text or Numbers

(Use this feature if you have a large database and you can’t manually find a cell that contains text or a
number you need to edit).

a) To search the entire worksheet, select any single cell. To search a range of cells, select that range only.

b) Choose Edit, Find to display the Find And Replace dialog box.

¢) In the Find What text box, enter the text or number you want to search for.

d) Click Find Next.

e) When you are done with your search , click Close to return to your spreadsheet.
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Part B: Linking Excel to the World Wide Web

Web pages often contain information that is perfect for analysis in Microsoft Excel. For example, you can
analyze stock quotes in Excel using information that comes directly from a Web page. Depending on your
needs, you can retrieve data that is refreshable (that is, you can update the data in Excel with the latest
data on the Web page) or you can get data from a Web page and keep it static on the worksheet.

16) Copying Static Data from Web Pages
a) Navigate to desired web page
b) Copy desired web data (Ctrl + C)
¢) Within Excel, click on desired cell where web data will be inserted

d) Paste web data into Excel spreadsheet (Ctrl + V)

17) Creating a refreshable Web Query within Excel

Address! jhttp:,l',l'manevcentral.msn.com,l'detail,l'stock_quat

Click [#*] next to the tables vou want ko select, then click

a) Within Excel, select the Data menu, point to Import External Data, and E:NHome | MyMSN | Hotmail | Shopping |
then click New Web Query. a 4 m
b) In the New Web Query dialog box enter the URL for the Web page msn™ Mon ey g‘“ '

from which you want to get data. S S
¢) Click Go. o —
d) Click on the arrows next to the tables you want to import or click in g

the upper left corner of the page to import the entire page.

e) Click import
f) Type or click on the desired cell location where you want the data to

IElName or Symbal: [8lk.amz

Masdaq quotes delayed 15

Quote, Chart, News Symhul Company Na

be positioned within Excel. St ALK Alaska Air G
Quates
Guate Detai AMIM  Amazon.cor

L L BHRE BE R it SRS

18) Refreshing a Web Query
a) Click a cell in the region of the worksheet where your query data was

returned External Data -, x
b) Select Refresh Data form the Data Menu (alternatively you can click on o, BT # bicl

the Refresh Data icon (a fat red exclamation point on the External Data

toolbar).

¢) A spinning globe (the refresh icon) appears to indicate the query is running. Double-click the icon to
check the status of the query.
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19) Importing a refreshable web query from Internet Explorer.

This method works well when you are surfing the internet and find a = fh

web page containing data that you would like to insert into an Excel =~ “w 07 '-fi

document.

a) Lauch Internet Explorer and navigate to the desired web pa
with the data you want to import.

b) Click on the Export to Excel Toolbar button

c) Select “Edit with Excel” and when the web page opens with
yellow arrows next to each HTML table that can be imported

[ Edit with Motepad

Taxes

My Money

A0S Edit with Microsoft Excel
Edit with Microsoft FronkPage
Edit with Microsaft Publisher

select the appropriate table and click on Import. ort Dats

d) At the Import Data screen prompt you can either choose to Wi o e e e e
import the data to a new worksheet or to a specific cell @ Existing werksheet: .
within the existing worksheet. v |=EE

() Mew worksheet
Hint: (Click on the desired cell to let Excel determine
the appropriate cell address).

20) Using Smart Tags

You can use smart tags to perform actions in Microsoft Excel that you'd usually open other programs to
perform. For example, if you type a U.S. financial symbol such as MSFT in a cell, the Smart Tag Actions

button provides a list of smart tag actions you can perform. The purple triangle in the corner of a
worksheet cell indicates smart tags.

To turn smart tags on:

a) On the Tools menu, click AutoCorrect options.
b) Click the Smart Tags tab, and select the Label data with smart tags

check box.

¢) A small purple triangle in the lower right corner will indicate the MSFT .
presence of a smart tag.

To use smart tags: MSFT

1) Position your cursor over the purple triangle. An information drop

down menu will appear. —— leemoaaoaoooioioas

2) Click on the drop down menu to display smart tag options.

21) Inserting a refreshable stock quote using Smart Tags
a) Make sure smart tags are turned on (see item #20 above).
b) Type the name of a recognized financial symbol in one of the cells (use all capital letters).
c¢) Click on the smart tag information button to the right of the small purple triangle.
d) Choose Insert Refreshable Stock Quote
See item #18 for steps on how to refresh a web query.

22) Inserting Dates and Times whose values are updated.
Use the TODAY and NOW functions to accomplish this task
a) Position your cursor where you want the date or time to show up.
b) To insert an updated date enter the function: =TODAY () in the formula bar.
¢) To insert an updated time enter the function: =NOW() in the formula bar.
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The date and time will be updated every time the workbook is saved, closed and opened again.
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